CDSA

Vulnerability and Patch Report, May 28, 2017 (Citadel Information Group)

[svg-table-content]

Important Security Updates

AxCrypt: AxCrypt has released version 2.1.1502.0. Updates are available from AxCrypt’s website.

Piriform CCleaner: Piriform has released version 5.30.6065 for CCleaner. Updates are available from Piriform’s website.

TechSmith Corporation SnagIt: TechSmith has released version 13.1.3.7993 for SnagIt. Updates are available from TechSmith’s website.

Viber: Viber has released version 6.8.1.16 for Windows. Updates are available on Viber’s website.

VLC Media Player: VLC has released version 2.2.6 (32-bit and 64-bit) of its Media Player. Download from the VLC website.

Current Software Versions

Adobe Flash 25.0.0.171

Adobe Reader DC 2017.009.20044

Dropbox 26.4.23 [Citadel warns against relying on security of Dropbox or other cloud-based file exchange systems. We recommend files containing sensitive information be independently encrypted with a program like Axcrypt; encryption keys be at least 15 characters long; and the master Dropbox [or other] password be at least 15 characters long and different from other passwords.]

Firefox 53.0.3 [Windows]

Google Chrome 58.0.3029.110

Internet Explorer 11.0.9600.18639

Java SE 8 Update 131 [Citadel recommends removing or disabling Java from your browser. Java is a major source of cyber criminal exploits. It is not needed for most internet browsing. If you have a particular web site that requires Java, Citadel recommends using a two-browser approach to minimize risk. If you normally browse the Web with Firefox, for example, disable the Java plugin in Firefox and use an alternative browser — such as Chrome, IE9, Safari, etc — with Java enabled to browse only the sites that require it.]

Microsoft Edge 40.15063.0.0

QuickTime 7.7.9 [Citadel recommends removing QuickTime. On April 14, 2016 US-CERT advised Microsoft Windows users to remove QuickTime. This followed a report in ars technica that Apple has no plans to update the Windows app despite at least two reliable QuickTime vulnerabilities that threaten Windows users who still have the program installed.]

Safari 10.1.1 [Mac OS X Mavericks, Yosemite, El Capitan]

Skype 7.36.0.101

For Your IT Department

Cisco Multiple Products: Cisco has released updates to address vulnerabilities in TelePresence IX5000 Series, FirePOWER System Software, CallManager Express, Integrated Management Controller, MS17-010 (Ransomware WannyCry), and others. Apply updates. Additional details are available at Cisco’s website.

McAfee ePolicy Orchestrator: McAfee has released an update to address multiple Oracle Java vulnerabilities in ePolicy Orchestrator. Apply updates. More details are available at McAfee’s website.

Samba: Samba has released security updates that address a vulnerability in all versions of Samba from 3.5.0 onward. A remote attacker could exploit this vulnerability to take control of an affected system. US-CERT is encouraging users and administrators to review Samba’s Security Announcement and apply the necessary updates, or refer to their Linux or Unix-based OS vendors for appropriate patches.

Trend Micro ServerProtect for Linux: Trend Micro has released an update after multiple vulnerabilities were found in ServerProtect. More information is available from Trend Micro’s website