CDSA

Vulnerability and Patch Report, May 21, 2017 (Citadel Information Group)

[svg-table-content]

Important Security Updates

Adobe Flash Player: Adobe has released version 25.0.0.171. Updates are available from Adobe’s website. To see which version you have, go to Adobe’s web page.

Google Chrome: Google has released Google Chrome version 58.0.3029.110. Updates are available from within the browser or from Google Chrome’s website.

LastPass: LastPass has released version 4.1.51 for its Free Password Manager. Updates are available from LastPass’ website.

Malwarebytes: Malwarebytes has released version 3.1.2.1733. Updates are available from Malwarebytes website.

Microsoft Patch Tuesday: Microsoft’s Patch Tuesday released updates to address dozens of vulnerabilities, some of which are highly critical within Windows operating systems, Microsoft Edge, Internet Explorer, Office, and other Microsoft products.  One update fixes a dangerous flaw present in most of Microsoft’s anti-malware technology that’s being called the worst Windows bug in recent memory. Additional details are available at Microsoft’s website.

Opera: Opera has released version 45.0.2552.635. Updates are available from within the browser or from Opera’s website.

Skype: Skype has released Skype 7.36.0.101. Updates are available from the program or Skype’s website.

Current Software Versions

Adobe Flash 25.0.0.171

Adobe Reader DC 2017.009.20044

Dropbox 25.4.28 [Citadel warns against relying on security of Dropbox or other cloud-based file exchange systems. We recommend files containing sensitive information be independently encrypted with a program like Axcrypt; encryption keys be at least 15 characters long; and the master Dropbox [or other] password be at least 15 characters long and different from other passwords.]

Firefox 53.0.2 [Windows]

Google Chrome 58.0.3029.110

Internet Explorer 11.0.9600.18639

Java SE 8 Update 131 [Citadel recommends removing or disabling Java from your browser. Java is a major source of cyber criminal exploits. It is not needed for most internet browsing. If you have a particular web site that requires Java, Citadelrecommends using a two-browser approach to minimize risk. If you normally browse the Web with Firefox, for example, disable the Java plugin in Firefox and use an alternative browser — such as Chrome, IE9, Safari, etc — with Java enabled to browse only the sites that require it.]

Microsoft Edge 40.15063.0.0

QuickTime 7.7.9 [Citadel recommends removing QuickTime. On April 14, 2016 US-CERT advised Microsoft Windows users to remove QuickTime. This followed a report in ars technica that Apple has no plans to update the Windows app despite at least two reliable QuickTime vulnerabilities that threaten Windows users who still have the program installed.]

Safari 10.1 [Mac OS X Mavericks, Yosemite, El Capitan]

Skype 7.36.0.101

For Your IT Department

Cisco Multiple Products: Cisco has released updates to address vulnerabilities in Integrated Management Controller, Intel Active Management Technology, AsyncOS Software for Cisco ESA Filtering, WebEx Meetings Server, IOS and IOS XE Software and others. Apply updates. Additional details are available at Cisco’s website.

McAfee ePolicy Orchestrator: McAfee’s website.McAfee has released an update to address a vulnerability in ePolicy Orchestrator. Apply the update. Additional details are available at McAfee’s website.